Why is my question being skipped? ...PLEASE HELP FIND MY PACKAGES!!!!!!

Asked by Cosentino | 5/17/2017 4:23:54 PM

As you can see below I asked for an update 15 days ago and all questions before and after mine were answered. I was told these were in transit and would take up 60days...it has been nearly 90 days. If people had proper tracking information we wouldn't need to keep messaging, please give me some updated information. If my packages are lost please be honest.

Asked by Tastill | 5/2/2017 11:11:56 AM
I have the following packages for delivery to Canada and there doesn't seem to be any updated tracking information to locate the current whereabouts. It has been more than 60 + days and they still have not been delivered. When will I receive these?

RQ947141495CN
RS450500977CN

5 Answer(s)

Daisy 5/17/2017 6:24:27 PM

Hi Cosentino,

Tracking shows it's still en route to Canada. If a package couldn't be reached within three months, it may be lost.

debbielopez 8/7/2019 11:29:27 PM

My package is lost. I give up thanks for all your feedback ZZ958961757CN

Daisy 8/8/2019 6:26:09 PM

Hi debbielopez,

No tracking information for it. What's the courier for your package?

Jocelyn Jaffray 8/16/2019 3:40:17 PM

What does "Wuhan City, return to the right to cast" mean? This is the latest Tracking message, dated 30 July. This package was apparently shipped to New Zealand on or about 21/22 June. It is now 17 August. Is this package lost? Tracking number is LL473490986CN. Please advise where this package is, and when it can be expected in New Zealand. Thank you.

Daisy 8/16/2019 7:52:01 PM

Hi Jocelyn Jaffray,

Don't wait for it. It has been returned back to the seller on July 30. It was sent to the wrong country Holand and then returned back. You need to contact the seller to require them to send it again to you or refund you as soon as possible.

Related Questions

Answer This Question

The User Name field is required. The 'User Name' field must be a string with a maximum length of 30.
The Email field is required. The Email field is not correct in format!