Did not received package

Asked by Kim Cox/Asselin | 10/9/2020 12:26:00 PM

Ordered 2 chairs from Hongshan District, Wuhan on July 8/20. Said it was delivered August 24/20 to my home but I never received these packages. I would need the information for these packages so I can give it to PayPal to be reimbursed. Thank You

Track Your Package

4 Answer(s)

Daisy 10/11/2020 3:00:47 AM

Hi Kim Cox/Asselin,

In general, if it's not delivered to your address, you need to contact the seller to ask if the tracking number is right. The seller may give you a tracking number of another customer. If the number is right, he may filled the address by mistake. If all are right, you need to contact the courier who delivered it in your country to reflect the problem and check it for you as soon as possible. The seller should give you a solution at last if you couldn't get it.

Kim Cox/Asselin 10/12/2020 9:29:31 AM

I would appreciate if you could look into this further because I am needing weight and shipment details which China post should have. Tracking number is correct and it is saying that the package was delivered to my address but I did not receive anything. Please help. Thank You

Daisy 10/12/2020 8:27:17 PM

Hi Kim Cox/Asselin,

Sorry, we don't have weight and shipment details.

If the tracking number is right, you need to contact the courier who delivered it in your country to reflect the problem and check it for you as soon as possible. The seller should give you a solution if you couldn't get it at last .

Kim 10/13/2020 6:48:13 PM

The seller has closed shop and Canada Post says they are not given any of that information. They don’t weigh the parcel. The parcel is weighed by China Post so the seller can get a price to ship it. I already have the tracking number but it says parcel has been delivered but parcel was not delivered to my door so I have no information.

Related Questions

Answer This Question

The User Name field is required. The 'User Name' field must be a string with a maximum length of 30.
The Email field is required. The Email field is not correct in format!