China Post: 86 10 11185 EMS: 86 10 11183

© Copyright 2021 chinapostaltracking.com

Package was stuck in ZhengZhou: CH088657236US

|

Hi Daisy,
I shipped a package to Henan with tracking# CH088657236US. It is stuck in ZhengZhou since 1/16/2020. It may still be there. I thought it will be delivered after covid-19 has blew over.
Could you please check and ask them to deliver this package for me?
Thanks for your helps!
Gary

2 Answer(s)

Hi Gary,

It's waiting the recipient to pay for the tax.

Number: CH088657236US
Package status: Expired
Country: United States -> China
2020-01-16 17:28, Zhengzhou, import customs retained pending inspection
2020-01-16 10:42, Zhengzhou, taxable mail, to be paid by the recipient
2020-01-16 10:11, Zhengzhou, sent to import customs
2020-01-16 01:40, Zhengzhou City, leaving the Post Zhengzhou Auto Mail Transfer Station, the next stop , International Mail Processing Center (via transfer)
2020-01-15 21:56, Zhengzhou City, arriving at the Post Zhengzhou Automail Transfer Station (via transfer)
2020-01-15 02:47, Shanghai, leaving the Shanghai Central Bureau Mail Processing Center, the next stop , Post Zhengzhou Auto Mail Transfer Station (via transfer)
2020-01-15 01:12, Shanghai, arriving at the Shanghai Central Bureau Mail Processing Center (via transfer)
2020-01-14 10:53, Shanghai, Import Customs Release
2020-01-14 00:07, Shanghai, sent to import customs
2020-01-11 23:46, New York, New York has been exported directly
2020-01-11 11:54, New York, Leaving New York
2020-01-11 11:53, New York, Arrival s/he agency
2020-01-11 11:05, New York, leaving the Overseas Export Swap Office (not yet arriving at China Post)
2020-01-11 11:05, New York, Arrival s/he agency
2020-01-09 12:46, U.S., U.S.A. Received
My package has been in customs in Shenzhen since the 5th October 2020. Is there any chance to find out when it will be released.

Related Questions

Answer This Question

The User Name field is required. The 'User Name' field must be a string with a maximum length of 30.
The Email field is required. The Email field is not correct in format!